Apache Royale communication with ColdFusion

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Apache Royale communication with ColdFusion

Faqpro
Hi,

First of all, I tried to follow the steps of
https://github.com/apache/royale-asjs/wiki/Apache-Royale-communication-with-AMF-and-RemoteObject
and I just managed to make it work the first time. Now every time I run mvn
clean install the following error appears:

[ERROR] Failed to execute goal on project RemoteObjectAMFTest-MXRoyale:
Could not resolve dependencies for project
org.apache.royale.examples:RemoteObjectAMFTest-MXRoyale:swf:0.9.6-SNAPSHOT:
Could not find artifact com.adobe.flash.framework:playerglobal:swc:20.0 in
apache-release (https://repository.apache.org/content/repositories/releases)

Is a problem with the repository?

On the other hand, my goal is to make the Royale-Coldfusion connection as I
did in the previous version of Flex. Has someone managed to do this
successfully?

I have several applications in flex but the step to Royale is not being as I
expected, at least in this aspect.

Regards



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Apache Royale communication with ColdFusion

Piotr Zarzycki
Hi Fabian,

I can tell you how to resolve that - Maven needs playerglobal to pass trough farther. Simply download player global from here [1] and put it in maven folder [2]
I know that is a bit cumbersome solution, but it's just the quickest one without going into too much details or investigating what has happened on your PC.

[2] .m2\repository\com\adobe\flash\framework\playerglobal\20.0\playerglobal-20.0.swc

Thanks,
Piotr

śr., 30 sty 2019 o 17:39 Faqpro <[hidden email]> napisał(a):
Hi,

First of all, I tried to follow the steps of
https://github.com/apache/royale-asjs/wiki/Apache-Royale-communication-with-AMF-and-RemoteObject
and I just managed to make it work the first time. Now every time I run mvn
clean install the following error appears:

[ERROR] Failed to execute goal on project RemoteObjectAMFTest-MXRoyale:
Could not resolve dependencies for project
org.apache.royale.examples:RemoteObjectAMFTest-MXRoyale:swf:0.9.6-SNAPSHOT:
Could not find artifact com.adobe.flash.framework:playerglobal:swc:20.0 in
apache-release (https://repository.apache.org/content/repositories/releases)

Is a problem with the repository?

On the other hand, my goal is to make the Royale-Coldfusion connection as I
did in the previous version of Flex. Has someone managed to do this
successfully?

I have several applications in flex but the step to Royale is not being as I
expected, at least in this aspect.

Regards



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/


--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki

Reply | Threaded
Open this post in threaded view
|

Re: Apache Royale communication with ColdFusion

Faqpro
Thanks Piotr,

The examples are running now but the css style don't load because I see
this:

<http://apache-royale-users.20374.n8.nabble.com/file/t102/nocss.png>

Do you know what may be happening?



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Apache Royale communication with ColdFusion

Piotr Zarzycki
What browser do you use ? What is your IDE ? 

czw., 31 sty 2019 o 13:54 Faqpro <[hidden email]> napisał(a):
Thanks Piotr,

The examples are running now but the css style don't load because I see
this:

<http://apache-royale-users.20374.n8.nabble.com/file/t102/nocss.png>

Do you know what may be happening?



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/


--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki

Reply | Threaded
Open this post in threaded view
|

Re: Apache Royale communication with ColdFusion

Faqpro
I normally use Chrome or Safari and Moonshine or FB

El 31 ene 2019, a las 13:58, Piotr Zarzycki <[hidden email]> escribió:

What browser do you use ? What is your IDE ? 

czw., 31 sty 2019 o 13:54 Faqpro <[hidden email]> napisał(a):
Thanks Piotr,

The examples are running now but the css style don't load because I see
this:

<http://apache-royale-users.20374.n8.nabble.com/file/t102/nocss.png>

Do you know what may be happening?



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/


--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki


Reply | Threaded
Open this post in threaded view
|

Re: Apache Royale communication with ColdFusion

Piotr Zarzycki
Fabian,

It looks like that example wasn't properly configured with Moonshine - I just pushed fix for it, so it will be available with newest nightly build. In the meantime you can configure it yourself.

Right click on project in Moonshine and choose Settings. Paste in "Additional compiler options"
-html-template=src/main/resources/jewel-example-index-template.html -theme=${royalelib}/themes/JewelTheme/src/main/resources/defaults.css

It should work.

Thanks,
Piotr

czw., 31 sty 2019 o 14:04 Fabian M <[hidden email]> napisał(a):
I normally use Chrome or Safari and Moonshine or FB

El 31 ene 2019, a las 13:58, Piotr Zarzycki <[hidden email]> escribió:

What browser do you use ? What is your IDE ? 

czw., 31 sty 2019 o 13:54 Faqpro <[hidden email]> napisał(a):
Thanks Piotr,

The examples are running now but the css style don't load because I see
this:

<http://apache-royale-users.20374.n8.nabble.com/file/t102/nocss.png>

Do you know what may be happening?



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/


--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki




--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki

Reply | Threaded
Open this post in threaded view
|

Re: Apache Royale communication with ColdFusion

Carlos Rovira-2
Maybe Fabian is not using Jewel, but using mx/Spark emulation.
Take into account that right now only Jewel has designed look and feel with themes.

El jue., 31 ene. 2019 a las 14:27, Piotr Zarzycki (<[hidden email]>) escribió:
Fabian,

It looks like that example wasn't properly configured with Moonshine - I just pushed fix for it, so it will be available with newest nightly build. In the meantime you can configure it yourself.

Right click on project in Moonshine and choose Settings. Paste in "Additional compiler options"
-html-template=src/main/resources/jewel-example-index-template.html -theme=${royalelib}/themes/JewelTheme/src/main/resources/defaults.css

It should work.

Thanks,
Piotr

czw., 31 sty 2019 o 14:04 Fabian M <[hidden email]> napisał(a):
I normally use Chrome or Safari and Moonshine or FB

El 31 ene 2019, a las 13:58, Piotr Zarzycki <[hidden email]> escribió:

What browser do you use ? What is your IDE ? 

czw., 31 sty 2019 o 13:54 Faqpro <[hidden email]> napisał(a):
Thanks Piotr,

The examples are running now but the css style don't load because I see
this:

<http://apache-royale-users.20374.n8.nabble.com/file/t102/nocss.png>

Do you know what may be happening?



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/


--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki




--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki



--