Install Royale

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Install Royale

dw1970
Hi,
I am new to Royale. Followed the
https://apache.github.io/royale-docs/get-started/download-royale to install
royale using
npm install @apache-royale/royale-js-swf -g

but got
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated request@2.88.2: request has been deprecated, see
https://github.com/request/request/issues/3142

changed 215 packages, and audited 216 packages in 30s

37 packages are looking for funding
  run `npm fund` for details

4 high severity vulnerabilities

Some issues need review, and may require choosing
a different dependency.

Run `npm audit` for details.

C:\Users\David>npm audit
found 0 vulnerabilities

Any idea how to rectify? or should I ignore it and continue the
installation?




--
Sent from: http://apache-royale-users.20374.n8.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: Install Royale

Bilbosax
This is just a personal preference, of course, do whatever you are most
comfortable with.  But I THINK that using npm will only get you version
0.9.7, which is way outdated at this point.  If I were you, I would suggest
installing Moonshine IDE.  They have a very simple button click to download
the nightly 0.9.8 version, and then you can point whatever IDE you are using
to the SDK that it downloads.  I find it to be the easiest and most straight
forward approach to stay on top of Royale on a regular basis.



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/