Rename of Jewel "Slider" to "HSlider"

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Rename of Jewel "Slider" to "HSlider"

Carlos Rovira-2
Hi,

for anyone using Jewel Slider, just notice that I rename this component to HSlider since we now have a VSlider too, in order to have consistency in names.

Sorry for any inconvenience, but seems a pretty simple refactor in your code.

Thanks

--
Reply | Threaded
Open this post in threaded view
|

Re: Rename of Jewel "Slider" to "HSlider"

Piotr Zarzycki
Hi Carlos,

Good change in my opinion. I was thinking about the same some time ago ;)

Thanks,
Piotr

On Thu, Nov 14, 2019, 12:13 AM Carlos Rovira <[hidden email]> wrote:
Hi,

for anyone using Jewel Slider, just notice that I rename this component to HSlider since we now have a VSlider too, in order to have consistency in names.

Sorry for any inconvenience, but seems a pretty simple refactor in your code.

Thanks

--
Reply | Threaded
Open this post in threaded view
|

Re: Rename of Jewel "Slider" to "HSlider"

Carlos Rovira-2
Hi Piotr,

as Greg introduced VSlider a refactor was needed. When I started "Slider" I think in a bead or property to get H or V orientations, but implementation reality in JS to make it work in most of the browsers makes it difficult to abstract implement. Since other sets has already HSlider/VSlider, this seems the most logic way to go :)

Another thing I consider was to maintain Slider name as an Alias through library catalog, but since we are under 1.0, I think is better to force the are name,

great you like it! :)

Carlos



El jue., 14 nov. 2019 a las 7:11, Piotr Zarzycki (<[hidden email]>) escribi├│:
Hi Carlos,

Good change in my opinion. I was thinking about the same some time ago ;)

Thanks,
Piotr

On Thu, Nov 14, 2019, 12:13 AM Carlos Rovira <[hidden email]> wrote:
Hi,

for anyone using Jewel Slider, just notice that I rename this component to HSlider since we now have a VSlider too, in order to have consistency in names.

Sorry for any inconvenience, but seems a pretty simple refactor in your code.

Thanks

--


--