compiler errors

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

compiler errors

Carlos Cruz

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos

Reply | Threaded
Open this post in threaded view
|

Re: compiler errors

Piotr Zarzycki

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr


On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos

Reply | Threaded
Open this post in threaded view
|

Re: compiler errors

Piotr Zarzycki

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr


On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr


On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos

Reply | Threaded
Open this post in threaded view
|

RE: compiler errors

Carlos Cruz

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To: [hidden email]
Cc: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos

Reply | Threaded
Open this post in threaded view
|

Re: compiler errors

Piotr Zarzycki

Carlos,

On monday I will try 1.6.0 with FlexJS Store and let you know.

Piotr


On Fri, Oct 27, 2017, 20:37 Carlos Cruz <[hidden email]> wrote:

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To: [hidden email]
Cc: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos

Reply | Threaded
Open this post in threaded view
|

Re: compiler errors

Piotr Zarzycki
Hi Carlos,

I just tried Moonshine 1.6.0 with Apache FlexJS 0.8.0 downloaded by Apache Flex Installer. I've created new FlexJS project with following settings - screenshot:

Obraz w treści 1

Note that I didn't choose an any SDK, cause I have setup an SDK in File -> Settings -> Default SDK.

I run from menu Project -> "Build as JavaScript" and build was successful. Do you have similar setup ? 

Thanks, Piotr


2017-10-27 20:50 GMT+02:00 Piotr Zarzycki <[hidden email]>:

Carlos,

On monday I will try 1.6.0 with FlexJS Store and let you know.

Piotr


On Fri, Oct 27, 2017, 20:37 Carlos Cruz <[hidden email]> wrote:

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To: [hidden email]
Cc: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos




--

Piotr Zarzycki 

mobile: +48 880 859 557 
skype: zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21

Reply | Threaded
Open this post in threaded view
|

RE: compiler errors

Carlos Cruz

Hi Piotr;

 

I just did it as you described below (not defining an SDK, personally I think having SDK Not Set a bit confusing) but one thing I notice that is different in our screens is I have an option to Select Template Type, any particular reason why?

 

 

When I import the project this error alert shows up:

 

I define the project

 

When I build as javascript I’m still getting the invalid SDK

To confirm I have the default SDK setup I’m including a print screen

 

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Monday, October 30, 2017 7:23 AM
To: [hidden email]
Subject: Re: compiler errors

 

Hi Carlos,

 

I just tried Moonshine 1.6.0 with Apache FlexJS 0.8.0 downloaded by Apache Flex Installer. I've created new FlexJS project with following settings - screenshot:

 

Obraz w treści 1

 

Note that I didn't choose an any SDK, cause I have setup an SDK in File -> Settings -> Default SDK.

 

I run from menu Project -> "Build as JavaScript" and build was successful. Do you have similar setup ? 

 

Thanks, Piotr

 

 

2017-10-27 20:50 GMT+02:00 Piotr Zarzycki <[hidden email]>:

Carlos,

On monday I will try 1.6.0 with FlexJS Store and let you know.

Piotr

 

On Fri, Oct 27, 2017, 20:37 Carlos Cruz <[hidden email]> wrote:

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To: [hidden email]
Cc: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos



 

--

Piotr Zarzycki 

mobile: +48 880 859 557 
skype: 
zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21

Reply | Threaded
Open this post in threaded view
|

Re: compiler errors

Piotr Zarzycki
Hi Carlos,

I know what has happened. You are using option "Open Apache Flex/JS Project..." - It opens both type of project, but you have to choose which type are opening in the next step. 
In that case you have to open drop down and choose "Flex Broswer Project (FlexJS)"

Obraz w treści 1

I went in my test by different path - I just choose from menu File -> New -> Flex Browser Project (FlexJS) - That's why I didn't have this "Select Template Type". 

Let me know if it helps.

Thanks for trying Moonshine! Piotr



2017-10-30 18:31 GMT+01:00 Carlos Cruz <[hidden email]>:

Hi Piotr;

 

I just did it as you described below (not defining an SDK, personally I think having SDK Not Set a bit confusing) but one thing I notice that is different in our screens is I have an option to Select Template Type, any particular reason why?

 

 

When I import the project this error alert shows up:

 

I define the project

 

When I build as javascript I’m still getting the invalid SDK

To confirm I have the default SDK setup I’m including a print screen

 

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Monday, October 30, 2017 7:23 AM
To: [hidden email]
Subject: Re: compiler errors

 

Hi Carlos,

 

I just tried Moonshine 1.6.0 with Apache FlexJS 0.8.0 downloaded by Apache Flex Installer. I've created new FlexJS project with following settings - screenshot:

 

Obraz w treści 1

 

Note that I didn't choose an any SDK, cause I have setup an SDK in File -> Settings -> Default SDK.

 

I run from menu Project -> "Build as JavaScript" and build was successful. Do you have similar setup ? 

 

Thanks, Piotr

 

 

2017-10-27 20:50 GMT+02:00 Piotr Zarzycki <[hidden email]>:

Carlos,

On monday I will try 1.6.0 with FlexJS Store and let you know.

Piotr

 

On Fri, Oct 27, 2017, 20:37 Carlos Cruz <[hidden email]> wrote:

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To: [hidden email]
Cc: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos



 

--

Piotr Zarzycki 

mobile: <a href="tel:+48%20880%20859%20557" value="+48880859557" target="_blank">+48 880 859 557 
skype: 
zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21




--

Piotr Zarzycki 

mobile: +48 880 859 557 
skype: zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21

Reply | Threaded
Open this post in threaded view
|

Re: compiler errors

Piotr Zarzycki

Carlos,

Did you able to build example with FlexJS?

Thanks, Piotr


On Mon, Oct 30, 2017, 18:45 Piotr Zarzycki <[hidden email]> wrote:
Hi Carlos,

I know what has happened. You are using option "Open Apache Flex/JS Project..." - It opens both type of project, but you have to choose which type are opening in the next step. 
In that case you have to open drop down and choose "Flex Broswer Project (FlexJS)"

Obraz w treści 1

I went in my test by different path - I just choose from menu File -> New -> Flex Browser Project (FlexJS) - That's why I didn't have this "Select Template Type". 

Let me know if it helps.

Thanks for trying Moonshine! Piotr



2017-10-30 18:31 GMT+01:00 Carlos Cruz <[hidden email]>:

Hi Piotr;

 

I just did it as you described below (not defining an SDK, personally I think having SDK Not Set a bit confusing) but one thing I notice that is different in our screens is I have an option to Select Template Type, any particular reason why?

 

 

When I import the project this error alert shows up:

 

I define the project

 

When I build as javascript I’m still getting the invalid SDK

To confirm I have the default SDK setup I’m including a print screen

 

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Monday, October 30, 2017 7:23 AM
To: [hidden email]
Subject: Re: compiler errors

 

Hi Carlos,

 

I just tried Moonshine 1.6.0 with Apache FlexJS 0.8.0 downloaded by Apache Flex Installer. I've created new FlexJS project with following settings - screenshot:

 

 

Note that I didn't choose an any SDK, cause I have setup an SDK in File -> Settings -> Default SDK.

 

I run from menu Project -> "Build as JavaScript" and build was successful. Do you have similar setup ? 

 

Thanks, Piotr

 

 

2017-10-27 20:50 GMT+02:00 Piotr Zarzycki <[hidden email]>:

Carlos,

On monday I will try 1.6.0 with FlexJS Store and let you know.

Piotr

 

On Fri, Oct 27, 2017, 20:37 Carlos Cruz <[hidden email]> wrote:

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To: [hidden email]
Cc: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos



 

--

Piotr Zarzycki 

mobile: <a href="tel:+48%20880%20859%20557" value="+48880859557" target="_blank">+48 880 859 557 
skype: 
zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21




--

Piotr Zarzycki 

mobile: +48 880 859 557 
skype: zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21


image004.png (85K) Download Attachment
image007.png (32K) Download Attachment
image002.png (99K) Download Attachment
image001.png (136K) Download Attachment
image005.png (9K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

RE: compiler errors

Carlos Cruz

Yes after I copied a newer versioin of java’s JRE into FB’s JRE directory I’m able to build the examples.

 

Thx!

Carlos

 

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Wednesday, November 1, 2017 2:01 PM
To: [hidden email]
Subject: Re: compiler errors

 

Carlos,

Did you able to build example with FlexJS?

Thanks, Piotr

 

On Mon, Oct 30, 2017, 18:45 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

 

I know what has happened. You are using option "Open Apache Flex/JS Project..." - It opens both type of project, but you have to choose which type are opening in the next step. 

In that case you have to open drop down and choose "Flex Broswer Project (FlexJS)"

 

Obraz w treści 1

 

I went in my test by different path - I just choose from menu File -> New -> Flex Browser Project (FlexJS) - That's why I didn't have this "Select Template Type". 

 

Let me know if it helps.

 

Thanks for trying Moonshine! Piotr

 

 

 

2017-10-30 18:31 GMT+01:00 Carlos Cruz <[hidden email]>:

Hi Piotr;

 

I just did it as you described below (not defining an SDK, personally I think having SDK Not Set a bit confusing) but one thing I notice that is different in our screens is I have an option to Select Template Type, any particular reason why?

 

 

When I import the project this error alert shows up:

 

I define the project

 

When I build as javascript I’m still getting the invalid SDK

To confirm I have the default SDK setup I’m including a print screen

 

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Monday, October 30, 2017 7:23 AM
To:
[hidden email]
Subject: Re: compiler errors

 

Hi Carlos,

 

I just tried Moonshine 1.6.0 with Apache FlexJS 0.8.0 downloaded by Apache Flex Installer. I've created new FlexJS project with following settings - screenshot:

 

 

Note that I didn't choose an any SDK, cause I have setup an SDK in File -> Settings -> Default SDK.

 

I run from menu Project -> "Build as JavaScript" and build was successful. Do you have similar setup ? 

 

Thanks, Piotr

 

 

2017-10-27 20:50 GMT+02:00 Piotr Zarzycki <[hidden email]>:

Carlos,

On monday I will try 1.6.0 with FlexJS Store and let you know.

Piotr

 

On Fri, Oct 27, 2017, 20:37 Carlos Cruz <[hidden email]> wrote:

I just created another hello world the error does not show up for the new project. But the FlexJSStore project that was imported still says to use another SDK.

 

From: Piotr Zarzycki [mailto:[hidden email]]
Sent: Friday, October 27, 2017 10:47 AM
To:
[hidden email]
Cc:
[hidden email]
Subject: Re: compiler errors

 

Carlos,

Once you experienced error with sdk and you go back to hello world App - do you still have it?

Thanks,
Piotr

 

On Fri, Oct 27, 2017, 16:35 Piotr Zarzycki <[hidden email]> wrote:

Hi Carlos,

In case of Moonshine we know about the issue. Doug experienced something similar [1]. In the next version it should be fixed, but I'm not sure yet when we will release it. I can only suggest that you can try to sources and build development version. I will let you know once we release 1.7.0.

[1] https://github.com/prominic/Moonshine-IDE/issues/16

Piotr

 

On Fri, Oct 27, 2017, 16:25 Carlos Cruz <[hidden email]> wrote:

Before I started the task of building Royale sources since I couldn’t find the binaries, I thought I would try latest version of FlexJS, but I’m having some issues I was wondering if anyone had experienced similar problems.

Installed Apache FlexJS 0.8.0 with the installer

Using flash builder 4.7 64 bit I create a Flex Project, converted it to FlexJS project or FlexJS MVC (with same result), I get the following error:  message = Uncaught exception in compiler Plug-in = com.adobe.flexbuilder.project

 

I’ve also tried Moonshine:

When I run a simple hello world application is compiles and runs the JS application

 

But when I try to compile and run FlexJSStore example that came with the FlexJS 0.8.0 SDK I get the following error: Invalid SDK - Please configure a Flex SDK instead

This is where the location of the SDK: C:\Program Files\Adobe\Adobe Flash Builder 4.7 (64 Bit)\sdks\flexJS-0.8.0

 

 

Thx!

Carlos



 

--

Piotr Zarzycki 

mobile: <a href="tel:+48%20880%20859%20557" target="_blank">+48 880 859 557 
skype: 
zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21



 

--

Piotr Zarzycki 

mobile: +48 880 859 557 
skype: 
zarzycki10

LinkedIn: http://www.linkedin.com/piotrzarzycki

GitHubhttps://github.com/piotrzarzycki21