moonshine compiler error.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

moonshine compiler error.

serkan.tas


Hi,

when i try to build my appi, i got the error below :

Error: Unable to access jarfile
..\apache-royale-0.9.1-bin-js-swf\royale-asjs\lib\fcsh.jar

when i searched ti, found that the jar is located under
\apache-flex-sdk-4.16.1-bin\lib

how can i fix it ?

downloaded flex sdk : apache-flex-sdk-4.16.1-bin.zip

downloaded royale sdk : apache-royale-0.9.1-bin-js-swf.zip

note : when located the folder apache-royale-0.9.1-bin-js-swf for sdk
home to the moonshine, not accepted then I located

apache-royale-0.9.1-bin-js-swf\royale-asjs as home for sdk.


Reply | Threaded
Open this post in threaded view
|

Re: moonshine compiler error.

Piotr Zarzycki
Hi Serkan,

If you are using Rojale swf,js version you need to make additional setup.

However if you are not going to build application to swf, but you are interested in only JS output. Download JSonly version and you should be good.

Yes in downloaded archive you should point in Moonshine to folder royale-asjs.

Thanks, Piotr

On Sun, Mar 4, 2018, 18:20 Serkan Taş <[hidden email]> wrote:


Hi,

when i try to build my appi, i got the error below :

Error: Unable to access jarfile
..\apache-royale-0.9.1-bin-js-swf\royale-asjs\lib\fcsh.jar

when i searched ti, found that the jar is located under
\apache-flex-sdk-4.16.1-bin\lib

how can i fix it ?

downloaded flex sdk : apache-flex-sdk-4.16.1-bin.zip

downloaded royale sdk : apache-royale-0.9.1-bin-js-swf.zip

note : when located the folder apache-royale-0.9.1-bin-js-swf for sdk
home to the moonshine, not accepted then I located

apache-royale-0.9.1-bin-js-swf\royale-asjs as home for sdk.


Reply | Threaded
Open this post in threaded view
|

Re: moonshine compiler error.

Piotr Zarzycki
Btw. Are you trying to build existing Flex application using Royale? 

On Sun, Mar 4, 2018, 19:44 Piotr Zarzycki <[hidden email]> wrote:
Hi Serkan,

If you are using Rojale swf,js version you need to make additional setup.

However if you are not going to build application to swf, but you are interested in only JS output. Download JSonly version and you should be good.

Yes in downloaded archive you should point in Moonshine to folder royale-asjs.

Thanks, Piotr

On Sun, Mar 4, 2018, 18:20 Serkan Taş <[hidden email]> wrote:


Hi,

when i try to build my appi, i got the error below :

Error: Unable to access jarfile
..\apache-royale-0.9.1-bin-js-swf\royale-asjs\lib\fcsh.jar

when i searched ti, found that the jar is located under
\apache-flex-sdk-4.16.1-bin\lib

how can i fix it ?

downloaded flex sdk : apache-flex-sdk-4.16.1-bin.zip

downloaded royale sdk : apache-royale-0.9.1-bin-js-swf.zip

note : when located the folder apache-royale-0.9.1-bin-js-swf for sdk
home to the moonshine, not accepted then I located

apache-royale-0.9.1-bin-js-swf\royale-asjs as home for sdk.


Reply | Threaded
Open this post in threaded view
|

Re: moonshine compiler error.

serkan.tas
I want to have js version but first trying to check if it is compiling with royale.

I also tried to generate api report but not successful.

Android için Outlook uygulamasını edinin



Kimden: Piotr Zarzycki
Gönderildi: 04 Mart Pazar 21:45
Konu: Re: moonshine compiler error.
Btw. Are you trying to build existing Flex application using Royale? 

On Sun, Mar 4, 2018, 19:44 Piotr Zarzycki <[hidden email]> wrote:
Hi Serkan,

If you are using Rojale swf,js version you need to make additional setup.

However if you are not going to build application to swf, but you are interested in only JS output. Download JSonly version and you should be good.

Yes in downloaded archive you should point in Moonshine to folder royale-asjs.

Thanks, Piotr

On Sun, Mar 4, 2018, 18:20 Serkan Taş <[hidden email]> wrote:


Hi,

when i try to build my appi, i got the error below :

Error: Unable to access jarfile
..\apache-royale-0.9.1-bin-js-swf\royale-asjs\lib\fcsh.jar

when i searched ti, found that the jar is located under
\apache-flex-sdk-4.16.1-bin\lib

how can i fix it ?

downloaded flex sdk : apache-flex-sdk-4.16.1-bin.zip

downloaded royale sdk : apache-royale-0.9.1-bin-js-swf.zip

note : when located the folder apache-royale-0.9.1-bin-js-swf for sdk
home to the moonshine, not accepted then I located

apache-royale-0.9.1-bin-js-swf\royale-asjs as home for sdk.




Reply | Threaded
Open this post in threaded view
|

Re: moonshine compiler error.

Piotr Zarzycki
Hi Serkan

I think I know what has happened. I believe we will have to make some adjustment in Moonshine to have report generation through that IDE. In the mean time please make generation using console command instead IDE using that instruction [1].

If you want to use SWF version of Royale I believe you need to follow [2]


Thanks,
Piotr



2018-03-04 21:04 GMT+01:00 Serkan Taş <[hidden email]>:
I want to have js version but first trying to check if it is compiling with royale.

I also tried to generate api report but not successful.

Android için Outlook uygulamasını edinin



Kimden: Piotr Zarzycki
Gönderildi: 04 Mart Pazar 21:45
Konu: Re: moonshine compiler error.
Btw. Are you trying to build existing Flex application using Royale? 

On Sun, Mar 4, 2018, 19:44 Piotr Zarzycki <[hidden email]> wrote:
Hi Serkan,

If you are using Rojale swf,js version you need to make additional setup.

However if you are not going to build application to swf, but you are interested in only JS output. Download JSonly version and you should be good.

Yes in downloaded archive you should point in Moonshine to folder royale-asjs.

Thanks, Piotr

On Sun, Mar 4, 2018, 18:20 Serkan Taş <[hidden email]> wrote:


Hi,

when i try to build my appi, i got the error below :

Error: Unable to access jarfile
..\apache-royale-0.9.1-bin-js-swf\royale-asjs\lib\fcsh.jar

when i searched ti, found that the jar is located under
\apache-flex-sdk-4.16.1-bin\lib

how can i fix it ?

downloaded flex sdk : apache-flex-sdk-4.16.1-bin.zip

downloaded royale sdk : apache-royale-0.9.1-bin-js-swf.zip

note : when located the folder apache-royale-0.9.1-bin-js-swf for sdk
home to the moonshine, not accepted then I located

apache-royale-0.9.1-bin-js-swf\royale-asjs as home for sdk.







--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki

Reply | Threaded
Open this post in threaded view
|

Re: moonshine compiler error.

serkan.tas

Hi Piotr,

Please find the script, report and errors in the attached file.


05.03.2018 11:20 tarihinde Piotr Zarzycki yazdı:
Hi Serkan

I think I know what has happened. I believe we will have to make some adjustment in Moonshine to have report generation through that IDE. In the mean time please make generation using console command instead IDE using that instruction [1].

If you want to use SWF version of Royale I believe you need to follow [2]


Thanks,
Piotr



2018-03-04 21:04 GMT+01:00 Serkan Taş <[hidden email]>:
I want to have js version but first trying to check if it is compiling with royale.

I also tried to generate api report but not successful.

Android için Outlook uygulamasını edinin



Kimden: Piotr Zarzycki
Gönderildi: 04 Mart Pazar 21:45
Konu: Re: moonshine compiler error.
Btw. Are you trying to build existing Flex application using Royale? 

On Sun, Mar 4, 2018, 19:44 Piotr Zarzycki <[hidden email]> wrote:
Hi Serkan,

If you are using Rojale swf,js version you need to make additional setup.

However if you are not going to build application to swf, but you are interested in only JS output. Download JSonly version and you should be good.

Yes in downloaded archive you should point in Moonshine to folder royale-asjs.

Thanks, Piotr

On Sun, Mar 4, 2018, 18:20 Serkan Taş <[hidden email]> wrote:


Hi,

when i try to build my appi, i got the error below :

Error: Unable to access jarfile
..\apache-royale-0.9.1-bin-js-swf\royale-asjs\lib\fcsh.jar

when i searched ti, found that the jar is located under
\apache-flex-sdk-4.16.1-bin\lib

how can i fix it ?

downloaded flex sdk : apache-flex-sdk-4.16.1-bin.zip

downloaded royale sdk : apache-royale-0.9.1-bin-js-swf.zip

note : when located the folder apache-royale-0.9.1-bin-js-swf for sdk
home to the moonshine, not accepted then I located

apache-royale-0.9.1-bin-js-swf\royale-asjs as home for sdk.







--

Piotr Zarzycki 

Patreon: https://www.patreon.com/piotrzarzycki



api-report.rar (5K) Download Attachment