royale-compiler environment preparation

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

royale-compiler environment preparation

Serkan Taş
Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan
Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Alex Harui-2

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Friday, November 16, 2018 at 12:49 PM
To: "[hidden email]" <[hidden email]>
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan

Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Serkan Taş
I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.


17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan


Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Alex Harui-2

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Friday, November 16, 2018 at 1:24 PM
To: "[hidden email]" <[hidden email]>
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.

17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan




Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Serkan Taş
Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>


17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.

17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan





Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Alex Harui-2

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Friday, November 16, 2018 at 1:41 PM
To: "[hidden email]" <[hidden email]>
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.


17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan








Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Serkan Taş
I am not sure what has gone wrong but i am going to work to discover.

But i did not get what you mean by your last sentence. I am trying to debug compiler to find-out why hanging during compile.

Sorry but i did not get the point while you say "
you need to run a build in royale-asjs first"

Is it required to debug compiler while compiling a project  ?

Thanks,
Serkan

17.11.2018 00:49 tarihinde Alex Harui yazdı:

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:41 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.


17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan









Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Alex Harui-2

IF you are going to run the compiler to compile your project, the compiler is going to need a working Royale SDK to supply the libraries needed for your app.  The wiki describes setting up run/debug configs against a royale-asjs repo that has been built with Ant so that the libraries exist.

 

So, assuming “ant” in royale-compiler worked, run “ant” in royale-typdefs and royale-asjs, then try a run/debug config.

 

HTH,

-Alex

 

From: Serkan Taş <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Friday, November 16, 2018 at 1:54 PM
To: "[hidden email]" <[hidden email]>
Subject: Re: royale-compiler environment preparation

 

I am not sure what has gone wrong but i am going to work to discover.

But i did not get what you mean by your last sentence. I am trying to debug compiler to find-out why hanging during compile.

Sorry but i did not get the point while you say "you need to run a build in royale-asjs first"

Is it required to debug compiler while compiling a project  ?

Thanks,
Serkan

17.11.2018 00:49 tarihinde Alex Harui yazdı:

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:41 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.



17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan













Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Serkan Taş

Thank you Alex, I looks like it will take some more effort and time make it work.

Serkan

17.11.2018 02:43 tarihinde Alex Harui yazdı:

IF you are going to run the compiler to compile your project, the compiler is going to need a working Royale SDK to supply the libraries needed for your app.  The wiki describes setting up run/debug configs against a royale-asjs repo that has been built with Ant so that the libraries exist.

 

So, assuming “ant” in royale-compiler worked, run “ant” in royale-typdefs and royale-asjs, then try a run/debug config.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:54 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I am not sure what has gone wrong but i am going to work to discover.

But i did not get what you mean by your last sentence. I am trying to debug compiler to find-out why hanging during compile.

Sorry but i did not get the point while you say "you need to run a build in royale-asjs first"

Is it required to debug compiler while compiling a project  ?

Thanks,
Serkan

17.11.2018 00:49 tarihinde Alex Harui yazdı:

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:41 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.



17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan














Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Serkan Taş
Hi Alex,

I made compiler work, thanks.

I found out that namespace definitons in the beginning of file - in application tag - causes compiler to hang.

e.g.

xmlns:comps="com.likya.pinara.comps.*"

When i remove these namespace definitions, than compiler goes on.

This workaround let me to continue but real solution is required for final.

Serkan


17.11.2018 09:20 tarihinde Serkan Taş yazdı:

Thank you Alex, I looks like it will take some more effort and time make it work.

Serkan

17.11.2018 02:43 tarihinde Alex Harui yazdı:

IF you are going to run the compiler to compile your project, the compiler is going to need a working Royale SDK to supply the libraries needed for your app.  The wiki describes setting up run/debug configs against a royale-asjs repo that has been built with Ant so that the libraries exist.

 

So, assuming “ant” in royale-compiler worked, run “ant” in royale-typdefs and royale-asjs, then try a run/debug config.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:54 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I am not sure what has gone wrong but i am going to work to discover.

But i did not get what you mean by your last sentence. I am trying to debug compiler to find-out why hanging during compile.

Sorry but i did not get the point while you say "you need to run a build in royale-asjs first"

Is it required to debug compiler while compiling a project  ?

Thanks,
Serkan

17.11.2018 00:49 tarihinde Alex Harui yazdı:

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:41 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.



17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan















Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Alex Harui-2

That’s a great discovery.  Can you then build a small test case that reproduces the problem so I can understand why it is hanging?

 

Thanks,

-Alex

 

From: Serkan Taş <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, November 17, 2018 at 7:34 AM
To: "[hidden email]" <[hidden email]>
Subject: Re: royale-compiler environment preparation

 

Hi Alex,

I made compiler work, thanks.

I found out that namespace definitons in the beginning of file - in application tag - causes compiler to hang.

e.g.

xmlns:comps="com.likya.pinara.comps.*"

When i remove these namespace definitions, than compiler goes on.

This workaround let me to continue but real solution is required for final.

Serkan

17.11.2018 09:20 tarihinde Serkan Taş yazdı:


Thank you Alex, I looks like it will take some more effort and time make it work.

Serkan

17.11.2018 02:43 tarihinde Alex Harui yazdı:

IF you are going to run the compiler to compile your project, the compiler is going to need a working Royale SDK to supply the libraries needed for your app.  The wiki describes setting up run/debug configs against a royale-asjs repo that has been built with Ant so that the libraries exist.

 

So, assuming “ant” in royale-compiler worked, run “ant” in royale-typdefs and royale-asjs, then try a run/debug config.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:54 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I am not sure what has gone wrong but i am going to work to discover.

But i did not get what you mean by your last sentence. I am trying to debug compiler to find-out why hanging during compile.

Sorry but i did not get the point while you say "you need to run a build in royale-asjs first"

Is it required to debug compiler while compiling a project  ?

Thanks,
Serkan

17.11.2018 00:49 tarihinde Alex Harui yazdı:

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:41 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.




17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan

















 



Reply | Threaded
Open this post in threaded view
|

Re: royale-compiler environment preparation

Serkan Taş
I am going to try but it will take time because it is not so easy to isolate the error from the codebase.

Thanks,
Serkan

18.11.2018 10:22 tarihinde Alex Harui yazdı:

That’s a great discovery.  Can you then build a small test case that reproduces the problem so I can understand why it is hanging?

 

Thanks,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Saturday, November 17, 2018 at 7:34 AM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Hi Alex,

I made compiler work, thanks.

I found out that namespace definitons in the beginning of file - in application tag - causes compiler to hang.

e.g.

xmlns:comps="com.likya.pinara.comps.*"

When i remove these namespace definitions, than compiler goes on.

This workaround let me to continue but real solution is required for final.

Serkan

17.11.2018 09:20 tarihinde Serkan Taş yazdı:


Thank you Alex, I looks like it will take some more effort and time make it work.

Serkan

17.11.2018 02:43 tarihinde Alex Harui yazdı:

IF you are going to run the compiler to compile your project, the compiler is going to need a working Royale SDK to supply the libraries needed for your app.  The wiki describes setting up run/debug configs against a royale-asjs repo that has been built with Ant so that the libraries exist.

 

So, assuming “ant” in royale-compiler worked, run “ant” in royale-typdefs and royale-asjs, then try a run/debug config.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:54 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I am not sure what has gone wrong but i am going to work to discover.

But i did not get what you mean by your last sentence. I am trying to debug compiler to find-out why hanging during compile.

Sorry but i did not get the point while you say "you need to run a build in royale-asjs first"

Is it required to debug compiler while compiling a project  ?

Thanks,
Serkan

17.11.2018 00:49 tarihinde Alex Harui yazdı:

Serkan,

 

I don’t have a “defaults” file or folder in my compiler-jx folder.  Something went wrong with your setup.

 

Maybe Eclipse put something there.  If you are trying to compile an app, then you need to run a build in royale-asjs first.

 

HTH,

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:41 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

Here it is:

PS D:\dev\royale-emulation-works\github\royale-compiler> git status
On branch develop
Your branch is up to date with 'origin/develop'.

nothing to commit, working tree clean
PS D:\dev\royale-emulation-works\github\royale-compiler>

17.11.2018 00:39 tarihinde Alex Harui yazdı:

The wiki is poorly formatted.  Are you sure you switched to the develop branch?  What does ‘git status’ say?

 

Post more of the log.  I can’t tell where in the build it is.

 

-Alex

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 1:24 PM
To: [hidden email] [hidden email]
Subject: Re: royale-compiler environment preparation

 

I have the clone of royale-asjs but not royale-typedefs

the file does not exist in clone and checked the git repo at https://github.com/apache/royale-asjs/tree/develop/frameworks/themes and can not see the file either.

Thanks.




17.11.2018 00:17 tarihinde Alex Harui yazdı:

Git clone royale-asjs and royale-typedefs.

 

From: Serkan Taş [hidden email]
Reply-To: [hidden email] [hidden email]
Date: Friday, November 16, 2018 at 12:49 PM
To: [hidden email] [hidden email]
Subject: royale-compiler environment preparation

 

Hi,

When i am trying to execute compiler within eclipse i am getting errors about some missing files :

D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\themes\Spark\spark.css'.
defaults (line: -1)
D:\dev\royale-emulation-works\github\royale-compiler\compiler-jx\defaults Error: unable to open 'D:\dev\royale-emulation-works\github\royale-asjs\frameworks\royale-config.xml'.
defaults (line: -1)


i prepared the environment according to : https://github.com/apache/royale-compiler/wiki/Eclipse-setup

Thanks,
Serkan