rs model / tag

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

rs model / tag

Mandeep Sarma
Hi,

I've been trying out some of the examples. some of the examples (i.e. RoyaleWebsite) use the <rs:model> tag. but when I compile I get the message: "This tag could not be resolved to an ActionScript class. It will be ignored."

Has this model been deprecated or am I misunderstanding something ?

Mandeep

Virus-free. www.avg.com
Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Alex Harui-2
What are you using to compile the example?  Ant, Maven, command-line, NPM?  I think the Ant and Maven builds work.

I don't see rs:model in RoyaleWebsite.  Maybe it got accidentally added by your editor?

-Alex

From: Mandeep Sarma <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, February 17, 2018 at 7:48 PM
To: "[hidden email]" <[hidden email]>
Subject: rs model / tag

Hi,

I've been trying out some of the examples. some of the examples (i.e. RoyaleWebsite) use the <rs:model> tag. but when I compile I get the message: "This tag could not be resolved to an ActionScript class. It will be ignored."

Has this model been deprecated or am I misunderstanding something ?

Mandeep

Virus-free. www.avg.com
Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Mandeep Sarma
Sorry... I have no idea why I said model, anyways I think I mean "namespace" as in: xmlns:rs="library://ns.apache.org/royale/site"

If it matters I'm using moonshine 1.9.

Thanks,
Mandeep


Inline image 1

On Sun, Feb 18, 2018 at 12:19 AM, Alex Harui <[hidden email]> wrote:
What are you using to compile the example?  Ant, Maven, command-line, NPM?  I think the Ant and Maven builds work.

I don't see rs:model in RoyaleWebsite.  Maybe it got accidentally added by your editor?

-Alex

From: Mandeep Sarma <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, February 17, 2018 at 7:48 PM
To: "[hidden email]" <[hidden email]>
Subject: rs model / tag

Hi,

I've been trying out some of the examples. some of the examples (i.e. RoyaleWebsite) use the <rs:model> tag. but when I compile I get the message: "This tag could not be resolved to an ActionScript class. It will be ignored."

Has this model been deprecated or am I misunderstanding something ?

Mandeep

Virus-free. www.avg.com

Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Alex Harui-2
Maybe Piotr will have to look into that.  I'm not sure what it looks for.  The compiler should only care about having RoyaleSite.swc in frameworks/libs.  Maybe we need to add that namespace to royals-config.xml.  If you have Apache Ant or Apache Maven, you should be able to build the example.

RoyaleWebsite is an early prototype of building "any" website with Royale.  Our ASDoc is a working example.  Other examples, like DataBindingExample and RoyaleStore are better equivalents of what Flex did.

-Alex

From: Mandeep Sarma <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, February 17, 2018 at 10:01 PM
To: "[hidden email]" <[hidden email]>
Subject: Re: rs model / tag

Sorry... I have no idea why I said model, anyways I think I mean "namespace" as in: xmlns:rs="library://ns.apache.org/royale/site"

If it matters I'm using moonshine 1.9.

Thanks,
Mandeep


Inline image 1

On Sun, Feb 18, 2018 at 12:19 AM, Alex Harui <[hidden email]> wrote:
What are you using to compile the example?  Ant, Maven, command-line, NPM?  I think the Ant and Maven builds work.

I don't see rs:model in RoyaleWebsite.  Maybe it got accidentally added by your editor?

-Alex

From: Mandeep Sarma <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, February 17, 2018 at 7:48 PM
To: "[hidden email]" <[hidden email]>
Subject: rs model / tag

Hi,

I've been trying out some of the examples. some of the examples (i.e. RoyaleWebsite) use the <rs:model> tag. but when I compile I get the message: "This tag could not be resolved to an ActionScript class. It will be ignored."

Has this model been deprecated or am I misunderstanding something ?

Mandeep

Virus-free. www.avg.com

Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Piotr Zarzycki
Hi,

Please try to open and compile first simple Hello World. Let me know if it's working. I will try today open Royale website and build in Moonshine. I will get back to you in couple of hours. :)

Thanks,
Piotr

On Sun, Feb 18, 2018, 07:52 Alex Harui <[hidden email]> wrote:
Maybe Piotr will have to look into that.  I'm not sure what it looks for.  The compiler should only care about having RoyaleSite.swc in frameworks/libs.  Maybe we need to add that namespace to royals-config.xml.  If you have Apache Ant or Apache Maven, you should be able to build the example.

RoyaleWebsite is an early prototype of building "any" website with Royale.  Our ASDoc is a working example.  Other examples, like DataBindingExample and RoyaleStore are better equivalents of what Flex did.

-Alex

From: Mandeep Sarma <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, February 17, 2018 at 10:01 PM
To: "[hidden email]" <[hidden email]>
Subject: Re: rs model / tag

Sorry... I have no idea why I said model, anyways I think I mean "namespace" as in: xmlns:rs="library://ns.apache.org/royale/site"

If it matters I'm using moonshine 1.9.

Thanks,
Mandeep


Inline image 1

On Sun, Feb 18, 2018 at 12:19 AM, Alex Harui <[hidden email]> wrote:
What are you using to compile the example?  Ant, Maven, command-line, NPM?  I think the Ant and Maven builds work.

I don't see rs:model in RoyaleWebsite.  Maybe it got accidentally added by your editor?

-Alex

From: Mandeep Sarma <[hidden email]>
Reply-To: "[hidden email]" <[hidden email]>
Date: Saturday, February 17, 2018 at 7:48 PM
To: "[hidden email]" <[hidden email]>
Subject: rs model / tag

Hi,

I've been trying out some of the examples. some of the examples (i.e. RoyaleWebsite) use the <rs:model> tag. but when I compile I get the message: "This tag could not be resolved to an ActionScript class. It will be ignored."

Has this model been deprecated or am I misunderstanding something ?

Mandeep

Virus-free. www.avg.com

Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

piotrz
Administrator
In reply to this post by Mandeep Sarma
Mandeep,

I just look into that and didn't have any problem with configuration and
build using Moonshine 1.9.0 and released version of Royale 0.9.1 JS only.
Royale website didn't have also Moonshine IDE files in the repository I just
committed it.

My project configuration looks like that:

<http://apache-royale-users.20374.n8.nabble.com/file/t1/configuration_royalewebsite.png>

I setup Royale 0.9.1 JS only SDK in File -> Settings:
<http://apache-royale-users.20374.n8.nabble.com/file/t1/file_settings.png>

If you want you can copy Moonshine configuration file for this project which
I just committed [1] to see if it helps.

[1] https://goo.gl/tFjbpD

Thanks,
Piotr



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/
Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Mandeep Sarma
I believe my settings are similar to yours (as per my screenshot). 

What is the proper way to import an example project into moon shine? I have tried to do it manually and I've tried importing a flex project.

Thanks,
Mandeep

Inline image 1

On Sun, Feb 18, 2018 at 6:41 AM, piotrz <[hidden email]> wrote:
Mandeep,

I just look into that and didn't have any problem with configuration and
build using Moonshine 1.9.0 and released version of Royale 0.9.1 JS only.
Royale website didn't have also Moonshine IDE files in the repository I just
committed it.

My project configuration looks like that:

<http://apache-royale-users.20374.n8.nabble.com/file/t1/configuration_royalewebsite.png>

I setup Royale 0.9.1 JS only SDK in File -> Settings:
<http://apache-royale-users.20374.n8.nabble.com/file/t1/file_settings.png>

If you want you can copy Moonshine configuration file for this project which
I just committed [1] to see if it helps.

[1] https://goo.gl/tFjbpD

Thanks,
Piotr



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/

Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Piotr Zarzycki
Mandeep,

You have to just open them. Most of them were configured to work with Moonshine. Once you open there is possibility that something went wrong, so you need to check Project Settings. 

Are you pointing to the good Royale SDK folder. ? 

Did you try open Hello World?

Try also reseting all settings and setup again, than open Hello World. You can reset in File - General. I'm not in front of my PC, so may be wrong.

Thanks, Piotr



On Tue, Feb 20, 2018, 06:14 Mandeep Sarma <[hidden email]> wrote:
I believe my settings are similar to yours (as per my screenshot). 

What is the proper way to import an example project into moon shine? I have tried to do it manually and I've tried importing a flex project.

Thanks,
Mandeep

Inline image 1

On Sun, Feb 18, 2018 at 6:41 AM, piotrz <[hidden email]> wrote:
Mandeep,

I just look into that and didn't have any problem with configuration and
build using Moonshine 1.9.0 and released version of Royale 0.9.1 JS only.
Royale website didn't have also Moonshine IDE files in the repository I just
committed it.

My project configuration looks like that:

<http://apache-royale-users.20374.n8.nabble.com/file/t1/configuration_royalewebsite.png>

I setup Royale 0.9.1 JS only SDK in File -> Settings:
<http://apache-royale-users.20374.n8.nabble.com/file/t1/file_settings.png>

If you want you can copy Moonshine configuration file for this project which
I just committed [1] to see if it helps.

[1] https://goo.gl/tFjbpD

Thanks,
Piotr



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/

Reply | Threaded
Open this post in threaded view
|

Re: rs model / tag

Mandeep Sarma
thx, 
the Hello World project does work, but I will try to reset the settings.

Mandeep.

On Tue, Feb 20, 2018 at 2:58 AM, Piotr Zarzycki <[hidden email]> wrote:
Mandeep,

You have to just open them. Most of them were configured to work with Moonshine. Once you open there is possibility that something went wrong, so you need to check Project Settings. 

Are you pointing to the good Royale SDK folder. ? 

Did you try open Hello World?

Try also reseting all settings and setup again, than open Hello World. You can reset in File - General. I'm not in front of my PC, so may be wrong.

Thanks, Piotr



On Tue, Feb 20, 2018, 06:14 Mandeep Sarma <[hidden email]> wrote:
I believe my settings are similar to yours (as per my screenshot). 

What is the proper way to import an example project into moon shine? I have tried to do it manually and I've tried importing a flex project.

Thanks,
Mandeep

Inline image 1

On Sun, Feb 18, 2018 at 6:41 AM, piotrz <[hidden email]> wrote:
Mandeep,

I just look into that and didn't have any problem with configuration and
build using Moonshine 1.9.0 and released version of Royale 0.9.1 JS only.
Royale website didn't have also Moonshine IDE files in the repository I just
committed it.

My project configuration looks like that:

<http://apache-royale-users.20374.n8.nabble.com/file/t1/configuration_royalewebsite.png>

I setup Royale 0.9.1 JS only SDK in File -> Settings:
<http://apache-royale-users.20374.n8.nabble.com/file/t1/file_settings.png>

If you want you can copy Moonshine configuration file for this project which
I just committed [1] to see if it helps.

[1] https://goo.gl/tFjbpD

Thanks,
Piotr



--
Sent from: http://apache-royale-users.20374.n8.nabble.com/